< Installer un noyau AMD (k7) sous Ubuntu | Roozeec Linux Blog
1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 4, 00 out of 5)
Loading...Loading...

Installer un noyau AMD (k7) sous Ubuntu

Sous Linux Ubuntu (et autres) , des noyaux sont optimisés pour chaque type de processeurs. Je vais vous décrire ici l’installation pour un processeur AMD.Ceci plaira surement à un collègue qui m’en a parlé souvent (elp). Salut a toi !

Je précise que j’ai ma config graphique avec le driver propriétaire de Nvidia (non a jour, mais ca je ne le savais pas avant la manipulation). C’est important, car j’ai eu comme un petit soucis … mais vite réparé….

Le paquet à installer se nomme linux-k7. Une méthode simple aurait été apt-get install linux-k7, mais bon pour les allergiques à la ligne de commande et pour expliquer un petit peu tout ca, j’ai tout fait en mode graphique. Donc je lance Synaptic, et je recherche linux-k7, et ca me donne ceci :

Un clic droit pour sélectionner l’installation.

Le programme Synaptic me récapitule ce qu’il va faire et je clique sur Ajouter à la sélection

Les fichiers ajoutés sont mis en vert sur la liste :

Pour valider un clic sur Appliquer et c’est parti :

Encore un récapitulatif …. et je clique sur Appliquer :

Et c’est parti pour le téléchargement ….

Et l’installation ….

Et la configuration …

Après ca tout est terminé, j’édite le fichier /boot/grub/menu.lst du chargeur de boot car l’installateur a mis le nouveau noyau au début. Je change donc la valeur de bot du défaut à 0 :

default 0

title Ubuntu, kernel 2.6.15-27-k7
root (hd1,4)
kernel /boot/vmlinuz-2.6.15-27-k7 root=/dev/hdd5 ro quiet splash
initrd /boot/initrd.img-2.6.15-27-k7
savedefault
boot

title Ubuntu, kernel 2.6.15-27-k7 (recovery mode)
root (hd1,4)
kernel /boot/vmlinuz-2.6.15-27-k7 root=/dev/hdd5 ro single
initrd /boot/initrd.img-2.6.15-27-k7
boot

Je reboot le PC et là , gloups, plus d’environnement graphique qui se lance. Un message m’indique que le kernel que j’ai lancé est à la version Nvidia 1.0.8776 et que le serveur X possède la version 1.0.8762. Bon maintenant qu’est ce que je fait. Don’t panic et tout d’abord je me connecte sous mon compte car j’ai quand même l’invite de connexion. Premièrement , il me faut rétablir l’interface graphique avec les drivers de base , à savoir nv. Pour ceci je lance la commande suivante :

sudo nano /etc/X11/xorg.conf

Ce qui va lancer un éditeur de texte en ligne de commande sur le fichier xorg.conf. Je recherche la ligne où est noté le driver nvidia :

Driver nvidia

et je remplace par

Driver nv

Je sauvegarde avec Ctrl+O , Entrée , CTRL + X
Maintenant je relance X avec : startx , mon ecran de login apparait, et je peux me logguer sans problème.

Je relance synaptic pour rechercher nvidia, car j’avais installé les drivers avec Synaptic et la bingo ! que vois-je ? La source de mon erreur sur le paquet nvidia-glx :

En effet l’image au dessus montre bien que la version actuelle installée est 1.0.8762 et la version courante est 1.0.8776. De plus l’icone indique que la mise à jour est possible. Ni une ni deux, j’emboite le pas avec un clic droit pour la mise a jour sur ce paquet :

Je n’oublie pas de remodifier le fichier /etc/X11/xorg.conf de facon à remettre le driver nvidia dans la section Device :

J’ai confiance et je reboote. Après quelques instants , le serveur X se lance avec le logo Nvidia donc tout est ok. Une fois dans mon environnement, je vérifie quand même si le noyau chargé est correct avec la commande :

uname -a

et la réponse est : Linux Louannec 2.6.15-27-k7 #1 SMP PREEMPT Sat Sep 16 02:35:20 UTC 2006 i686 GNU/Linux

Voilà, tout est OK, ca roule. Que vais-je gagner avec ce noyau ? je ne sais pas encore….

Si vous avez aimé cet article, merci de voter pour lui ! :
Both comments and pings are currently closed.


Contrat Creative Commons
Cet article est sous licence Creative Commons Paternité
Partage des Conditions Initiales à l'Identique 2.0 France License

Comments are closed.

Propulsé par WordPress


Contrat Creative Commons
Site sous licence Creative Commons Paternité
Partage des Conditions Initiales à l'Identique 2.0 France License
Web Analytics