< Appareil Photo PTP et Gnome | Roozeec Linux Blog
1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading ... Loading ...

Appareil Photo PTP et Gnome

Mon APN n’ayant pas supporté le voyage l’hiver dernier au soleil, j’ai du en racheter un autre. Je suis désormais paré au cas où je pars en weekend de dernière minute au soleil. Après avoir pris quelques photos, je fais donc la manipulation habituelle pour importer celles-ci dans mon logiciel de gestion photos (digikam). Et là, ca ne fonctionne pas….

Ce billet va donc me servir de mémo car lors d’une prochaine installation Linux, ce soucis risque de m’arriver.

Je branche donc comme d’habitude mon cable usb à mon APN, et allume celui-ci. Dès la mise en marche ca commence mal, le message suivant apparait :

Gloups, que se passe-t-il ? Pourtant sur mon tableau de bord tout se passe bien, les icones de l’apn apparaissent correctement :

Et je peux me balader dans le montage effectué avec Nautilus et y voir mes photos :

Bon, que neni je me dis, et je continue mes opérations habituelles, et c’est là que ca coince. En effet, je lance digikam pour importer les photos dans mes albums comme je le fais habituellement. L’appareil est vu, donc cool…

Et bien, non c’est pas cool …

J’essaye donc par réflexe d’utiliser un autre programme de gestions photos, F-Spot. Meme problème …

Mon appareil est bien reconnu sous Ubuntu, je vérifie avec la commande lsusb :

Bus 001 Device 006: ID 040a:05d1 Kodak Co.

Je fais donc quelques recherches et je tombe sur le forum ubuntu-fr ou le problème est similaire :

Je fais donc la manip proposée :

gconftool –type Boolean –set /apps/nautilus/preferences/media_automount false

Je relance F-Spot ou digikam, et là ca fonctionne :

Maintenant, le petit problème est que le montage de tous les périphériques (clé usb, disque externe, etc …) ne se fait plus automatiquement. En effet, il faut aller sous Nautilus et cliquer sur l’icone du périphérique.

Ce n’est pas bien compliqué, c’est sur, mais quand on a pris l’habitude à quelque chose, c’est dur de s’en défaire…

Je pense qu’il est possible de contourner celà, peut-etre avec les règles Udev, mais sans certitude….

Voilà, à garder donc dans un petit coin au cas ou ça m’arrive encore.

Si vous avez aimé cet article, merci de voter pour lui ! :


Articles qui peuvent vous intéresser:

  1. Digikam et appareil photo numerique
  2. Album Photo PicassaWeb et Digikam
  3. Installer un theme d’icones facilement sous Gnome
  4. Diaporama photo avec Imagination et Openshot
  5. Faire des captures d’écran, de zones d’écran sous Gnome
Vous pouvez ajouter un commentaire, ou un trackback à partir de votre site.


Contrat Creative Commons
Cet article est sous licence Creative Commons Paternité
Partage des Conditions Initiales à l'Identique 2.0 France License

2 Responses to “Appareil Photo PTP et Gnome”

  1. temps dit :

    J’ai comme un problème similaire avec les sd card sur des dell latitude I7. J’ai opté pour une autre solution, je me suis fais un petit bash qui lance la card SD. Ceci me permet de ne pas désactiver media_automount .
    Cordialement

  2. Pierrot_tk dit :

    Je fais plus simple.
    Avant chaque téléchargement des photos de mon Nikon D700 à l’aide de Digikam, je fais la manipulation manuelle suivante.
    1. Je branche et allume l’APN (Nikon D700)qui va se monter automatiquement
    2. Ouvrir Nautilus
    3. Je démonte le D700 par click sur le triangle gris.
    4. Je peux maintenant utiliser le téléchargement sous Digikam (je n’ai pas essayé d’autres logiciels)
    Mes clefs usb continuent donc de se monter automatiquement :)

Leave a Reply

Propulsé par WordPress


Contrat Creative Commons
Site sous licence Creative Commons Paternité
Partage des Conditions Initiales à l'Identique 2.0 France License
Web Analytics